I’m trying to create the kubernetes cluster from scratch following the instructions taken from https://github.com/entando-k8s/entando-helm-quickstart because I need to customize the platform to connect to an external db (postgres).

I’m currently using minikube locally to test the platform and i customized values.yaml with parameters in order to connect to the external db

after i run

helm template quickstart ./ | kubectl apply -n entando-f -

pods like quickstart-kc-deployer quickstart-composite-app-deployer fails

suggestions ?

logs from quickstart-composite-app-deployer-4249

2021-09-21 13:50:40,189 INFO [org.ent.kub.con.sup.cli.EntandoResourceClient] (main) Exiting method updateStatus in class org.entando.kubernetes.controller.support.client.EntandoResourceClient
2021-09-21 13:50:40,189 SEVERE [org.ent.kub.mod.com.EntandoCompositeAppController] (main) Unexpected exception occurred while adding EntandoKeycloakServer entando/quickstart-kc
2021-09-21 13:50:40,190 SEVERE [org.ent.kub.mod.com.EntandoCompositeAppController] (main) Unexpected exception occurred while adding EntandoCompositeApp entando/quickstart-composite-app: org.entando.kubernetes.controller.support.controller.EntandoControllerException: Unexpected exception occurred while adding EntandoKeycloakServer entando/quickstart-kc
at org.entando.kubernetes.compositeapp.controller.EntandoCompositeAppController.synchronizeDeploymentState(EntandoCompositeAppController.java:95)
at org.entando.kubernetes.compositeapp.controller.EntandoCompositeAppController.synchronizeDeploymentState(EntandoCompositeAppController.java:56)

logs from quickstart-kc-deployer-1680

2021-09-21 13:50:38,900 INFO [org.ent.kub.con.sup.cli.IngressClient] (main) Exiting method createIngress in class org.entando.kubernetes.controller.support.client.IngressClient
2021-09-21 13:50:38,901 SEVERE [org.ent.kub.mod.key.EntandoKeycloakServerController] (main) Unexpected exception occurred while adding EntandoKeycloakServer entando/quickstart-kc: io.fabric8.kubernetes.client.KubernetesClientException: Failure executing: POST at: Message: 404 page not found
at io.fabric8.kubernetes.client.dsl.base.OperationSupport.requestFailure(OperationSupport.java:568)
at io.fabric8.kubernetes.client.dsl.base.OperationSupport.assertResponseCode(OperationSupport.java:507)
at io.fabric8.kubernetes.client.dsl.base.OperationSupport.handleResponse(OperationSupport.java:471)
at io.fabric8.kubernetes.client.dsl.base.OperationSupport.handleResponse(OperationSupport.java:430)
at io.fabric8.kubernetes.client.dsl.base.OperationSupport.handleCreate(OperationSupport.java:251)
at io.fabric8.kubernetes.client.dsl.base.BaseOperation.handleCreate(BaseOperation.java:807)
at io.fabric8.kubernetes.client.dsl.base.BaseOperation.create(BaseOperation.java:322)
at io.fabric8.kubernetes.client.dsl.base.BaseOperation.create(BaseOperation.java:318)

thanks in advance

Hey, @a.renzi.

My guess is your networking config isn’t quite right. That’s the typical error you get if the the configured address isn’t reachable on the network. We don’t have exact instructions for minikube but there are some tips on things to try here, including using .nip.io as a suffix to deal with similar issues - https://dev.entando.org/v6.3.2/docs/reference/local-tips-and-tricks.html#network-issues.

One test is to spin up a simple container running a webserver and make sure you can access it from your host machine/laptop. That will separate the network issue from the actual Entando config. I’ve had issues working this out in various Windows configurations but it can also be sensitive to routers on your local network or firewall settings.

Hope that helps,

Hi @nathan.shaw

Yesterday I had the same problem described by a.renzi
I simply followed the getting started guide for entering 6.3.2 (manual installation) and “tips and tricks - network problem” as suggested by you.
This didn’t solve my problem:
Unexpected exception occurred while adding EntandoKeycloakServer entando/quickstart-kc: io.fabric8.kubernetes.client.KubernetesClientException: Failure executing: POST at: Message: 404 page not found

So i started digging into google and i found that the extensions/v1beta1 and networking.k8s.io/v1beta1 API versions of Ingress is no longer served as of v1.22.
So i checked my version of k3s (it was v1.23.5) and found the problem … at least i think …
I reinstalled k3s with the version option
curl -sfL https://get.k3s.io | INSTALL_K3S_VERSION = v1.20.15 + k3s1 sh -
and then everything worked out fine.
Maybe, if my solution is not wrong, it is better to include this option in the guide or is there a compatibility table between k8s and entando to read before installing?

thanks in advance

Hi, @gigiozzz.

Yes, your analysis was correct. Entando 6.3.2 at the moment supports up to Kubernetes v1.21. You can find the current compatibility guides here and a blog post on our updated approach here. Support for K8s 1.22 is undergoing testing now and we’re hoping to add it to Entando 6.3.2 soon.